Sign Up!
Login
Welcome to The Grim Admin
Saturday, March 25 2017 @ 03:45 AM EDT
 Forum Index >  Grim Admin Software and Scripts >  Screensaver Operations
 Re: ScreenSaver Operations and GPO pr...
   |  Printable Version
By: modulo (offline)  Wednesday, October 10 2012 @ 03:42 PM EDT (Read 10747 times)  
modulo

I am working on a project where I need to apply Group Policy to computers in a lab environment.
When I install the application and manually choose the screen saver the program works fine. However I need to apply Group Policy. I have noticed that when I apply group policy the screensaver will not launch. Group policy does load SSO as the default screen saver when I log in to the computer. In addition I have the Screensaver Operations.scr file in the sysWOW64 folder. The registry shows that I have ScreenSaveActive set to 1, ScreenSaveTime set to the time I set in group policy as well as SCRNSAVE.EXE set to Screensaver Operations.scr

The group policies I used are
Enable Screen Saver
Screen Saver timeout
Force Specific Screen Saver

I am running windows 7 64 bit.

Forum Grim Hatchling
Grim Hatchling

Registered: 10/10/12
Posts: 2

Profile Email    
   
By: Admin (offline)  Monday, October 29 2012 @ 03:32 PM EDT  
Admin

Make sure the settings for Windows 7 64-bit are as follows:

Enable screensaver: Enabled
Force specific screen saver: Screensaver Operations.scr
Password protect the screensaver: Disabled
Screeen saver timeout: Enabled (and then set the number of seconds you want. E.g., 1800)


If that's correct, can you try setting the Group Policy to another screensaver to rule out some setting that is getting in the way? For example, if the display power save mode is shorter than that of the screensaver, the screensaver will not load. You can also not use screensavers when using Remote Desktop (by design in Windows).

Forum Admin
Admin

Registered: 07/28/09
Posts: 14

Profile Email Website  
   
By: modulo (offline)  Monday, October 29 2012 @ 03:42 PM EDT  
modulo

Make sure the settings for Windows 7 64-bit are as follows:

Enable screensaver: Enabled
Force specific screen saver: Screensaver Operations.scr
Password protect the screensaver: Disabled
Screeen saver timeout: Enabled (and then set the number of seconds you want. E.g., 1800)


If that's correct, can you try setting the Group Policy to another screensaver to rule out some setting that is getting in the way? For example, if the display power save mode is shorter than that of the screensaver, the screensaver will not load. You can also not use screensavers when using Remote Desktop (by design in Windows).


I had to choose the absolute path to the screensaver to make it work.
Enable screensaver: Enabled
Force specific screen saver: C:\Windows\SysWOW64\Screensaver Operations.scr
Screeen saver timeout: Enabled

turn off display and put computer to sleep are both set to zero.

Forum Grim Hatchling
Grim Hatchling

Registered: 10/10/12
Posts: 2

Profile Email    
   


 All times are EDT. The time is now 03:45 am.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic w/ New Post Sticky Topic w/ New Post
Locked Topic w/ New Post Locked Topic w/ New Post
View Anonymous Posts 
Able to Post 
HTML Allowed 
Censored Content